We are seeing improvements in the transmission of fiscal records to Fiskaly. We will continue monitoring the situation and share a further update once the service is fully restored.
Posted May 24, 2026 - 15:37 CEST
Update
We are actively monitoring the ongoing Fiskaly maintenance and will provide an update once it has been completed. Customers with German fiscalization enabled may experience delays in bill printing during this period.
Posted May 24, 2026 - 15:07 CEST
Update
We are actively monitoring the ongoing Fiskaly maintenance and will provide an update once it has been completed. Customers with German fiscalization enabled may experience delays in bill printing during this period.
Posted May 24, 2026 - 14:47 CEST
Identified
We are monitoring the situation and we will keep you posted when Fiskaly is done with the maintenance. You might experience delayed bill printing if you have the German fiscalization enabled.