Delayed delivery of webhooks

Incident Report for Mews

Resolved

The issue has been fully resolved and the backlog of webhooks has been successfully processed. Webhooks are now operating normally with no further delays.
Posted Oct 21, 2025 - 15:38 CEST

Update

The issue of duplicate Connector API webhooks has been fixed. Sending webhooks is currently delayed by 5 to 8 hours (depending on webhook type). We expect the built up webhooks to be processed within 6 hours.

Note that other kinds of webhooks, like scheduled reports, are also affected and will be delivered with delay.
Posted Oct 21, 2025 - 08:57 CEST

Monitoring

The fix is now being rolled into production. We expect it will take a few hours for the webhooks backlog to clear and the delivery to normalize to regular delay rates.
Posted Oct 21, 2025 - 03:10 CEST

Identified

We have identified the cause of the issue related to recent changes in webhooks creation logic. We are preparing a hotfix for deployment to production.
Posted Oct 21, 2025 - 02:02 CEST

Update

We are continuing to investigate reports of duplicate and significantly delayed delivery of General Webhooks. Your operations may be impacted if you are using an integration partner who is using Webhooks.
Posted Oct 21, 2025 - 01:31 CEST

Investigating

We are investigating reports of duplicate and significantly delayed delivery of General Webhooks.
Posted Oct 21, 2025 - 01:21 CEST
This incident affected: Mews Open API.