Degraded performance
Incident Report for Mews
Postmortem

Problem

Degradation of database response time - overall application response time was elevated during 10 min.

Action

Recent changes on the index were manually rolled back.

Causes

To improve performance one existing index was updated. Even though the change seemed to be reasonable it affected the query plan selection in some corner cases. Thus, application response time was affected only 10 min in total during the whole 45 min incident.

Solutions

We will consume SQL diagnostic data and build an alert on top of it to catch query response degradation earlier.

Posted Feb 01, 2022 - 17:30 CET

Resolved
This incident has been resolved.
Posted Jan 25, 2022 - 11:30 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 25, 2022 - 11:22 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 25, 2022 - 11:01 CET
Investigating
We are experiencing degraded performance of our service due to slowed database. We are investigating.
Posted Jan 25, 2022 - 10:56 CET
This incident affected: Operations, Guest Journey, Business Intelligence, Payments, Open API, and Marketplace.